Ошибка при установлении защищённого соединения в Mozilla Firefox

При открытии одного довольно известного сайта в браузере Mozilla Firefox 62.0.3 по защищенному протоколу HTTPS, я столкнулся с такой ошибкой:

Ошибка при установлении защищённого соединения

Во время загрузки страницы соединение с www.site.ru было прервано.
Страница, которую вы пытаетесь просмотреть, не может быть отображена, так как достоверность полученных данных не может быть проверена.
Пожалуйста, свяжитесь с владельцами веб-сайта и проинформируйте их об этой проблеме.

Firefox Ошибка при установлении защищённого соединения Во время загрузки страницы соединение с было прервано.

В английской версии Firefox ошибка звучит так:

Secure Connection Failed

The connection to www.site.ru was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

Please contact the website owners to inform them of this problem.

firefox Secure Connection Failed The connection to www.site.ru was interrupted while the page was loading

При этом этот сайт нормально открывается в других браузерах (Chrome, Edge)

Данная проблема связан с тем, что владельцы сайта используют устаревшую версию сертификата, который при попытке установки HTTPS соединения с сайтом требует использовать старую небезопасную версию протокола TLS. В этом случае нужно связаться с администрацией сайта и попросить их обновить версию TLS. Понятно, что это возможно далеко не всегда.

Проверить поддерживаемую версию TLS для сайта можно с помощью онлайн иснтумента https://www.ssllabs.com/ssltest/. Просто укажите имя сайта (домена), сертификат которого вы хотите проверить и запустите сканирование.

После окончания сканирования (выполняется несколько минут) перейдите в секцию Configuration.

Как вы видите, в моем случае сертификат не поддерживает протокол TLS 1.3.

проверка версии tls

Чтобы открыть такой сайт в новых версиях браузера Mozilla Firefox, вам придется снизить уровень безопасности, требуемый к установке защищенного соединения.

  1. Откройте редактор тонкой настройки Firefox, набрав в адресной строке браузера about:config .
  2. С помощью поиска найдите параметр с именем: security.tls.version.max .
  3. В данном параметре указана максимальная доступная версия TLS. Значение 4 соответствует TLS 1.3, значение 3 — TLS 1.2. Измените значение security.tls.version.max с 4 на 3 и сохраните изменения. security.tls.version.max Firefox
  4. Попробуйте еще раз открыть сайт в браузере. Он должен открыться.
Совет. Возможные значение параметра и соответствующие им версии протоколов:

0 – устаревший SSL 3.0

1 – также устаревший TLS 1.0

2 – TLS 1.1

3 – TLS 1.2

Проверить версию протокола TLS, которую использует ваш браузер можно на странице https://www.howsmyssl.com/. При значении security.tls.version.max = 4, она должна отображать надпись.

Your client is using TLS 1.3, the most modern version of the encryption protocol. It gives you access to the fastest, most secure encryption possible on the web.

firefox поддержка tls 1.3

При смене значения security.tls.version.max на 3, на странице проверки будет указано, что ваш браузер использует TLS 1.2.

Чтобы не переключаться на менее защищенную версию протокола TLS для всех сайтов, можно добавить нужные сайт в список security.tls.insecure_fallback_hosts.

В некоторых антивирусах (ESET NOD32, Avast, Kaspersky) может быть включен модуль проверки SSL/TLS соединений. Если ошибка «Ошибка при установлении защищённого соединения» возникает при подключении ко многим сайтам, попробуйте отключить модуль сканирования SSL/TLS в настройках антивируса (см. подробности в статье: «Ошибка Chrome: этот сайт не может обеспечить безопасное соединение«.


Предыдущая статья Следующая статья


Комментариев: 2 Оставить комментарий

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Я не робот( Обязательно отметьте)